Android Wifi WPA2/WPA Connects and Disconnects issue


Recently i saw a weird issue that my friend faced with his Micromax Canvas Knight Android device running Kitkat 4.4.2 Operating System.

Issue :

When we tried to connect to the Wifi (ADSL) with WPA2 Security and TKIP encryption, after adding the password and trying to connect, Wifi gets connected, Wifi Symbol appears, and in a fraction of second it gets disconnected saying saved, secured with WPA2 under Wifi Settings.

As a first troubleshooting step we removed all the available Wifi Settings (long press on each of them + Forget) and tried to re-configuring but the same issue persisted.

We tried restarting the phone, changing Wifi router settings like removing WPA2 security, setting WPA security, changing TKIP to AES etc. but non worked.

We even tried connecting to some different Wifi router, but the same issue.

Solution :

There was a Antivirus Security App installed on the phone that had Administrative rights, we deleted that app and tried connecting the wifi and it worked :)

Didn't find this solution anywhere on the internet, so before trying to factory reset your phone, just try removing or configuring anti-virus applications that may be causing this issue.

⚡️ This is an old post may be contain outdated, or irrelevant to recent times.




Recent Posts:




Code2care is an initiative to publish and share varied knowledge in programming and technical areas gathered during day-to-day learnings and development activities.

Students and Software Developers can leverage this portal to find solutions to their various queries without re-inventing the wheel by referring to our easy to understand posts. Technical posts might include Learnings, Video Tutorials, Code Snippets, How Tos, Blogs, Articles, etc.