[Eclipse] Syntax error, annotations are only available if source level is 1.5 or greater


While working with eclipse J2EE IDE on Mac OS X system running Yosemite Operating system, I got the following error message Syntax error, annotations are only available if source level is 1.5

I have configured JRE with Java version JRE 1.8, to fix this issue,

  1. Right-click on your project folder and select Properties
  2. Now click on Java Compiler
  3. Change the Java Compiler Compliance level to 1.7 or higher
  4. Apply changes
  5. Issue should be fixed.

Note that older versions of Eclipse IDEs do not support Java 8 version. You need to have Eclipse Kepler SR2 or Eclipse Luna versions for Java 8 support.

Java Compiler Compliance level
Java Compiler Compliance level




Recent Posts:




Code2care is an initiative to publish and share varied knowledge in programming and technical areas gathered during day-to-day learnings and development activities.

Students and Software Developers can leverage this portal to find solutions to their various queries without re-inventing the wheel by referring to our easy to understand posts. Technical posts might include Learnings, Video Tutorials, Code Snippets, How Tos, Blogs, Articles, etc.