Your Android SDK is out of date or is missing templates. Please ensure you are using SDK version 22 or later.


Posted on : Tue, 13th Oct 15 09:04 am UTC
2314 votes
Error : Your Android SDK is out of date or is missing templates. Please ensure you are using SDK version 22 or later.

You may get this error if you already have Android Studio/Eclipse SDK installed on your computer. To resolve this issue all you need to do is update SDK version to 22 or later.

Solution :

  1. Open SDK Manager :

    Location Windows : \Users\<user-profile>\AppData\Local\Android\android-studio\sdk\
    Location Mac OS X : /Applications/Android/Studio.app/sdk/
  2. Update SDK tools from version 2.1 to 2.2

Code2care's mission is to share varied knowledge in technical and non-technical areas gathered during day-to-day learnings and development activities so that our visitors can leverage this portal to find solutions to their queries without re-inventing the wheel. Technical posts include Learnings, Tutorials, Video Tutorials, Code Snippets, Tips-n-tricks.

Follow us : Facebook - Twitter - Google +