[Eclipse] Syntax error, annotations are only available if source level is 1.5 or greater


Posted on : Tue, 8th Sep 15 01:04 pm (Updated on : Tue, 8th Sep 15 01:04 pm) GMT
Author : Code2care

While working with eclipse J2EE IDE on Mac OS X system running Yosemite Operating system, i got the following error message Syntax error, annotations are only available if source level is 1.5

I have configured JRE with Java version jre 1.8, to fix this issue,

  1. Right click on your project folder and select Properties
  2. Now click on Java Compiler
  3. Change the Java Compiler Compliance level to 1.7 or higher
  4. Apply changes
  5. Issue should be fixed.
Java Compiler Compliance level




Advertisements





Note that older versions of Eclipse IDEs do not support Java 8 version. You need to have Eclipse Kepler SR2 or Eclipse Luna versions for Java 8 support.


We are operating with limited resources due to COVID-19 - Stay Safe!


We stands in support of racial equality!

Follow us : Facebook - Twitter