Error:The SDK Build Tools revision (XX.X.X) is too low for project. Minimum required is XX.X.X


Posted on : Fri, 30th Jun 17 02:56 pm UTC
2314 votes
Error:The SDK Build Tools revision (22.0.1) is too low for project ':app'. Minimum required is 25.0.0 <a href="install.build.tools">Install Build Tools 25.0.0, update version in build file and sync project</a></br></a href="openFile:/Users/xxxxx/Downloads/AppName/app/build.gradle">Open File</a>
Solution : Click on the Console error, a SDK Quickfix Installation prompt should download the latest Android SDK Build-Tools version (25.0.0 in my case)
Name : Download logs
  
To install:
- Android SDK Build-Tools 25 (build-tools;25.0.0)
Preparing "Install Android SDK Build-Tools 25 (revision: 25.0.0)".
Downloading https://dl.google.com/android/repository/build-tools_r25-macosx.zip
"Install Android SDK Build-Tools 25 (revision: 25.0.0)" ready.
Finishing "Install Android SDK Build-Tools 25 (revision: 25.0.0)"
Installing Android SDK Build-Tools 25 in /Users/rakeshswami/Android/adt-bundle-mac-x86_64-20140702/sdk/build-tools/25.0.0
"Install Android SDK Build-Tools 25 (revision: 25.0.0)" complete.
"Install Android SDK Build-Tools 25 (revision: 25.0.0)" finished.
  

Code2care's mission is to share varied knowledge in technical and non-technical areas gathered during day-to-day learnings and development activities so that our visitors can leverage this portal to find solutions to their queries without re-inventing the wheel. Technical posts include Learnings, Tutorials, Video Tutorials, Code Snippets, Tips-n-tricks.

Follow us : Facebook - Twitter - Google +